Welcome, Guest. Please login or register.
May 28, 2022, 03:04:13 AM
Pages: [1]   Go Down
  Print  
Author Topic: RSX PRB/HF-1 Intake manifold  (Read 1755 times)
0 Members and 1 Guest are viewing this topic.
RoyaltyStanceNation
Fucking Newb
Posts: 1



Reputation Power: 1
RoyaltyStanceNation pfffft.
Trade Count: (0)

View Profile
« on: May 08, 2019, 01:54:04 AM »

Well since I blew up the transmission last summer and planned on pulling the motor w/ the trans. While the motor was out I decided it was a perfect time to do the rear main seal valve cover gaskets etc. I was looking at alternative Intake Manifolds for my engine and came across a K20A2 intake manifold. Swap it over to my motor and bought a Ktuned coolant block off/ bypass apdater. It all fit up as it’s supposed to. Also upgraded the injectors from 310cc to 550cc. Drop the motor and new trans back into the car. Started it back up and now the car is idling at 1500; which is normal at cold starts, but after being warmed up or at normal temperature the idle should taper off back down to 750. It does not; its stays at 1500 or when it get closer to operating temps rpms jump to 2000 rpm. My question is the new intake manifold cause the idle issues, bigger injectors, or both. There’s no vacuum leaks and can’t figure out why it’s idling so high. Any opinions or advice would be awesome!

Mods: K24A2 w/ Ktuner, factory 5speed, innovative 95A red mounts, stage 4 sprung 6 puck ceramic clutch kit w/ lightened flywheel, new pressure plate, new rear main seal, PRB HF-1 IM, Ktuned coolant bypass adapter, CAI, AEM Wideband, RC 550cc injectors, headers, test pipe, cat back exhaust system.






Sent from my iPhone using Tapatalk
Logged
ThePofPower
Fucking Newb
Posts: 7


Reputation Power: 1
ThePofPower pfffft.
Trade Count: (0)

View Profile
« Reply #1 on: September 27, 2019, 01:47:16 PM »

I see you posted back a few months ago, ya find the problem yet?
Well I know that you stated that it doesnt have any vacuum leaks but... The list of things that I can think of that would raise the idle would be
-Tune not corrected for the new injectors ( would run like ass )
-Lovely vacuum leaks, they can hide really well and be intermittent ( had a problem with my injector seals at 300K )
And as always when the motor is pulled out and or worked on often things that are not obvious are bumped or not reinstalled etc that can cause all kinds of problems.
was the throttle body TPS and idle up ( if applicable ) all calabrated in the tune ? The TPS can do weird shit
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

TinyPortal © 2005-2012